Page 1 of 1

DAP Programmer Always Losing Connection After a Few Seconds

Posted: Tue Sep 12, 2017 4:56 am
by farrellf
Hi,

I have a couple of these "RTLDUINO_PRO_V1.0" boards which contain a DAP programmer and an RTL-00 module:

https://www.digikey.com/product-detail/ ... ND/7033233

When I plug the USB cable into the top-left (DAP) USB connector, the device shows up as a 2MB USB HDD as expected. But no matter what I do, it disconnects after a few seconds, then reconnects, then disconnects, and finally fails with Device Manager showing an "Unknown USB Device (Device Descriptor Request Failed"

I have the mbed driver installed.

The weird thing is if I'm very quick, during those first few seconds where it shows up as a USB HDD, I *can* connect to it with OpenOCD... but I lose the connection within seconds.

I also tried plugging my USB cable directly into the RTL-00 module. Connecting to that serial port, at 38400 baud, and pressing the RST button on the module, I get this error:

=========================================================

ROM Version: 0.3

Build ToolChain Version: gcc version 4.8.3 (Realtek ASDK-4.8.3p1 Build 2003)

=========================================================
Check boot type form eFuse
SPI Initial
Image1 length: 0x0, Image Addr: 0x0
Image1 Validation Incorrect !!!
Please Re-boot and try again, or re-burn the flash image



So I'm guessing the RTL-00 was not factory programmed? But that should not cause the DAP programmer to disconnect as well, right?

Any help is appreciated.

Thanks,
-Farrell

Re: DAP Programmer Always Losing Connection After a Few Seconds

Posted: Wed Dec 27, 2017 1:08 pm
by Darkmoon_UK
I was suffering the same issue. At least in my case, this was due to an older firmware revision on my CMSIS-DAP and updating to the latest fixed it. The Ameba IoT project have released a number of newer versions which improve functional stability. Instructions and Downloads behind the registration wall at https://www.amebaiot.com .